Re: PATCH: Add memreserve to DTC
From: Jon Loeliger <hidden>
Date: 2005-07-15 14:30:58
On Fri, 2005-07-15 at 02:19, David Gibson wrote:
Ok, I've merged this,
Excellent, thanks!
although I've tweaked things substantially in the process.
No problem.
I did rename "header_tree" to "boot_info", moved some
Oh, good!
things around, and changed the syntax. Reserve ranges can now be specified either as an address and length: /memreserve/ 10000000 00002000; or as an (inclusive) address range: /memreserve/ 10000000-10001fff; I am a bit worried that those two forms may be hard to distinguish at a glance. Any sugggestions for changes to the syntax soon please, I'd really like to keep the source syntax as stable as possible.
Oh man. With syntax you can demystify those in any number
of ways. Just a matter of what you are wanting. You can
always add sugar:
/memreserve_block/ 10000000 00002000;
/memreserve_range/ 10000000 10001fff;
/memreserve/ 10000000 /for/ 2000; // or /size/ ?
/memreserve/ 10000000 /through/ 10001fff;
/memreserve/ 10000000 00002000;
/memreserve/ [10000000, 10001fff]; // or [10000000, 10002000)?
Stuff like that maybe?
jdl