Re: MPC52xx: sysfs failure on adding new device driver
From: Grant Likely <hidden>
Date: 2005-06-09 14:54:44
On 6/9/05, Sylvain Munaut [off-list ref] wrote:
=20 Grant Likely wrote:quoted
quoted
From what I can tell, I should be able to register more than onedriver for a particular device name (mpc52xx_psc).=20 I always assumed that yes. But now looking more closely, I'm not sure what I based that assumption on ... And if not the case that's indeed a problem because that's what's used to support the different function supported by the PSCs.
I was assuming so too, and it seems that the device structure would support it. Who would know the answer to this?
=20quoted
Otherwise I would need to change arch/ppc/syslib/mpc52xx_devices.c to have a different name for each psc.=20 No you shouldn't have to touch that. The mpc52xx_match_psc_function(idx, "spi") is there to know which driver should be used for what PSC and you're using it correctly so it _should_ work.
I thought so, if I disable the mpc52xx_uart driver then my driver will register correctly. I agree that it is not desireable to touch mpc52xx_devices.c
=20quoted
If I change the sysfs code to ignore the failure to create a directory then the driver seems to register fine.=20 A "better" quick-fix would be to change the platform_match (drivers/platform.c) to support "sub-fonctions". For example when using mpc52xx_psc.spi it only matches what's before the dot (if any) with the device name.
... so that a different directory will be created in sysfs for each driver? That's got possibilities.
=20 That changes the semantic of the driver names for the platform bus however, making the dot a "special" char.
Who needs to be asked about this? Should I take this discussion over the the LKML? Thanks, g.