Re: next pass of cleaning up micropatch.c
flat view
From: Tom Rini <hidden>
Date: 2004-10-08 15:46:37
On Fri, Oct 08, 2004 at 11:34:06AM -0400, Dan Malek wrote:
On Oct 8, 2004, at 8:44 AM, Robert P. J. Day wrote:quoted
+ * Shortcut macros for patching code. */ + +#define PATCH2000 \ + dp = (uint *)(commproc->cp_dpmem); \ + for (i=0; i<(sizeof(patch_2000)/4); i++) \ + *dp++ = patch_2000[i]; + +#define PATCH2E00 \ + dp = (uint *)&(commproc->cp_dpmem[0x0e00]); \ + for (i=0; i<(sizeof(patch_2e00)/4); i++) \ + *dp++ = patch_2e00[i]; + +#define PATCH2F00 \ + dp = (uint *)&(commproc->cp_dpmem[0x0f00]); \ + for (i=0; i<(sizeof(patch_2f00)/4); i++) \ + *dp++ = patch_2f00[i];Please get rid of these macros and place the code where it belongs. They add no value and just make it harder to read the code and understand what it does.
I agree. If there were more patches it might make sense to write a do_microcode_patch2(N) macro, but PATCH2NNN isn't "readable" and it's only 3 patches. -- Tom Rini http://gate.crashing.org/~trini/