On 14 Aug 1999, Jes Sorensen wrote:
David> #define eieio() __asm__ volatile("li 0,0: cmpwi 0,0; bne+ 0f;
David> eieio; 0:" : : : "0")
Defininf a C function with the name of a PPC specific assembler
function is pretty stupid. To the best of my knowledge wmb() is the
generic name for the thing you are looking for.
Keep in mind, I'm talking about MkLinux, _not_ LinuxPPC. wmb() is a
linux-specific term, as far as I know. The above is in mach.
David
[[ This message was sent via the linuxppc-dev mailing list. Replies are ]]
[[ not forced back to the list, so be sure to Cc linuxppc-dev if your ]]
[[ reply is of general interest. Please check http://lists.linuxppc.org/ ]]
[[ and http://www.linuxppc.org/ for useful information before posting. ]]