Re: [PATCH 3/3] xfs: rename buffer cache index variable b_bn
From: Christoph Hellwig <hch@infradead.org>
Date: 2021-08-12 08:25:16
From: Christoph Hellwig <hch@infradead.org>
Date: 2021-08-12 08:25:16
On Tue, Aug 10, 2021 at 03:28:51PM +1000, Dave Chinner wrote:
From: Dave Chinner <redacted> TO stop external users from using b_bn as the disk address of the buffer, rename it to b_index to indicate that it is the buffer cache index, not the block number of the buffer. Code that needs the disk address should use xfs_buf_daddr() to obtain it. Do the rename and clean up any of the remaining b_bn cruft that is left over and is now unused.
Looks good: Reviewed-by: Christoph Hellwig <hch@lst.de> Although the XFS_BUF_SET_ADDR really is a separate thing and should probably have been a separate patch.