On Sun, May 16, 2021 at 01:34:37PM -0700, Darrick J. Wong wrote:
On Sun, May 16, 2021 at 11:49:55PM +0800, Eryu Guan wrote:
quoted
On Tue, May 11, 2021 at 07:01:51PM -0700, Darrick J. Wong wrote:
quoted
From: Darrick J. Wong <djwong@kernel.org>
Refactor all the places where we try to force new file data allocations
to a specific xfs backing device so that we don't end up open-coding the
same xfs_io command lines over and over.
Signed-off-by: Darrick J. Wong <djwong@kernel.org>
---
common/populate | 2 +-
common/xfs | 25 +++++++++++++++++++++++++
tests/generic/223 | 3 ++-
tests/generic/449 | 2 +-
tests/xfs/004 | 2 +-
quoted
tests/xfs/088 | 1 +
tests/xfs/089 | 1 +
tests/xfs/091 | 1 +
tests/xfs/120 | 1 +
tests/xfs/130 | 1 +
I think above updates should be in a separate patch.
Why?
This patch is refactoring open-coded command into a helper, which should
not change the logic. But above changes are adding new users of this
helper and change test behavior. So I think they should be in a separate
patch for review.
Thanks,
Eryu