Re: [PATCH 1/2] common/xfs: support realtime devices with _scratch_xfs_admin
From: "Darrick J. Wong" <djwong@kernel.org>
Date: 2021-03-25 17:51:35
Also in:
fstests
From: "Darrick J. Wong" <djwong@kernel.org>
Date: 2021-03-25 17:51:35
Also in:
fstests
On Mon, Mar 22, 2021 at 09:20:37PM -0700, Darrick J. Wong wrote:
From: Darrick J. Wong <djwong@kernel.org> Teach _scratch_xfs_admin to support passing the realtime device to xfs_admin so that we can actually test xfs_admin functionality with those setups. Signed-off-by: Darrick J. Wong <djwong@kernel.org> --- common/xfs | 8 +++++++- 1 file changed, 7 insertions(+), 1 deletion(-)diff --git a/common/xfs b/common/xfs index 69f76d6e..9cb373ba 100644 --- a/common/xfs +++ b/common/xfs@@ -269,9 +269,15 @@ _test_xfs_db() _scratch_xfs_admin() { local options=("$SCRATCH_DEV") + local rtopts=()
NAK, this name is inconsistent with the rest of the function and stupid bash will just create the rt_opts array in the global namespace with no complaints whatsoever. --D
[ "$USE_EXTERNAL" = yes -a ! -z "$SCRATCH_LOGDEV" ] && \
options+=("$SCRATCH_LOGDEV")
- $XFS_ADMIN_PROG "$@" "${options[@]}"
+ if [ "$USE_EXTERNAL" = yes ] && [ -n "$SCRATCH_RTDEV" ]; then
+ $XFS_ADMIN_PROG --help 2>&1 | grep -q 'rtdev' || \
+ _notrun 'xfs_admin does not support rt devices'
+ rt_opts+=(-r "$SCRATCH_RTDEV")
+ fi
+ $XFS_ADMIN_PROG "${rt_opts[@]}" "$@" "${options[@]}"
}
_scratch_xfs_logprint()