Re: [PATCH 2/3] xfs: rename xfs_defer_join to xfs_defer_join_inode
From: Christoph Hellwig <hch@lst.de>
Date: 2017-08-17 07:44:24
On Wed, Aug 16, 2017 at 10:21:30AM -0700, Darrick J. Wong wrote:
On Sun, Aug 13, 2017 at 04:42:15PM +0200, Christoph Hellwig wrote:quoted
Signed-off-by: Christoph Hellwig <hch@lst.de> --- fs/xfs/libxfs/xfs_bmap.c | 2 +- fs/xfs/libxfs/xfs_defer.c | 4 ++-- fs/xfs/libxfs/xfs_defer.h | 2 +- 3 files changed, 4 insertions(+), 4 deletions(-)diff --git a/fs/xfs/libxfs/xfs_bmap.c b/fs/xfs/libxfs/xfs_bmap.c index c09c16b1ad3b..24eba36ef818 100644 --- a/fs/xfs/libxfs/xfs_bmap.c +++ b/fs/xfs/libxfs/xfs_bmap.c@@ -6452,7 +6452,7 @@ __xfs_bmap_add( bi->bi_whichfork = whichfork; bi->bi_bmap = *bmap; - error = xfs_defer_join(dfops, bi->bi_owner); + error = xfs_defer_join_inode(dfops, bi->bi_owner);/me wonders if this should be named xfs_defer_ijoin to be more consistent with xfs_trans_ijoin, or if we should rename the other one to xfs_trans_join_inode instead?
Sure. I'll resend with the __ prefix removed from __xfs_trans_roll and this renamed to _ijoin. Should I also rename xfs_trans_roll_inode to xfs_trans_roll_ijoin?