Re: [PATCH 1/9] xfs: use per-filesystem dquot LRU lists
From: Christoph Hellwig <hch@infradead.org>
Date: 2012-02-17 17:33:51
From: Christoph Hellwig <hch@infradead.org>
Date: 2012-02-17 17:33:51
On Thu, Feb 16, 2012 at 09:10:45AM +1100, Dave Chinner wrote:
Might be nice to add a + struct xfs_quotainfo *qi = dqp->q_mount->m_quotainfo; here to make the code a little easier to read and consistent with all the other functions. Regardless, change looks good.
Makes sense. I've done that and actually split the real final put into a separate xfs_qm_dqput_final function, and replaced the tail recursion with a real recursive call to xfs_qm_dqput for the group quota. Given that this is a fairly large amount of changes I didn't bother to add your reviewed by tag until it's getting re-reviewed. _______________________________________________ xfs mailing list xfs@oss.sgi.com http://oss.sgi.com/mailman/listinfo/xfs