Re: [PATCH 3/3] xfs: cleanup quota check on disk blocks and inodes reservations
From: HAYASAKA Mitsuo <hidden>
Date: 2012-02-03 04:06:04
Also in:
lkml
Hi Christoph Thank you for your comments. (2012/02/03 1:07), Christoph Hellwig wrote:
On Mon, Jan 23, 2012 at 12:45:43PM +0900, Mitsuo Hayasaka wrote:quoted
This patch is a cleanup of quota check on disk blocks and inodes reservations. Signed-off-by: Mitsuo Hayasaka <redacted> Cc: Ben Myers <redacted> Cc: Alex Elder <elder@kernel.org> Cc: Christoph Hellwig <hch@lst.de> --- fs/xfs/xfs_trans_dquot.c | 17 +++++++---------- 1 files changed, 7 insertions(+), 10 deletions(-)diff --git a/fs/xfs/xfs_trans_dquot.c b/fs/xfs/xfs_trans_dquot.c index c4ba366..5e6cd1c 100644 --- a/fs/xfs/xfs_trans_dquot.c +++ b/fs/xfs/xfs_trans_dquot.c@@ -605,7 +605,7 @@ xfs_trans_dqresv( time_t timer; xfs_qwarncnt_t warns; xfs_qwarncnt_t warnlimit; - xfs_qcnt_t count; + xfs_qcnt_t tcount;Can you call this variable total_count to make it a bit more obvious?
Sure.
quoted
+ tcount = *resbcountp + nblks; + if (hardlimit > 0ULL && tcount > hardlimit) {Given that xfs_qcnt_t is unsigned what about transforming this into the more readable: if (hardlimit && total_count > hardlimit) and similar for the others?
OK, I'm going to change them and send the revised patch series. Thanks. _______________________________________________ xfs mailing list xfs@oss.sgi.com http://oss.sgi.com/mailman/listinfo/xfs