Thread (3 messages) flat view 3 messages, 3 authors, 2021-12-08

Re: [PATCH] carl9170: Use the bitmap API when applicable

From: Christian Lamparter <hidden>
Date: 2021-12-03 07:57:28
Also in: kernel-janitors, lkml, netdev

On 01/12/2021 23:05, Christophe JAILLET wrote:
Use 'bitmap_zalloc()' to simplify code, improve the semantic and avoid some
open-coded arithmetic in allocator arguments.

Note, that this 'bitmap_zalloc()' divides by BITS_PER_LONG the amount of
memory allocated.
The 'roundup()' used to computed the number of needed long should have
been a DIV_ROUND_UP.


Also change the corresponding 'kfree()' into 'bitmap_free()' to keep
consistency.

Use 'bitmap_zero()' to avoid hand writing it.

Signed-off-by: Christophe JAILLET <redacted>
Acked-by: Christian Lamparter <redacted>
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help