Thread (2 messages) 2 messages, 2 authors, 2021-11-04

Re: [PATCH] ath5k: use swap() to make code cleaner

flat view

From: Jiri Slaby <jirislaby@kernel.org>
Date: 2021-11-04 09:38:09
Also in: lkml, netdev

On 04. 11. 21, 7:23, davidcomponentone@gmail.com wrote:
From: Yang Guang <redacted>

Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid
opencoding it.
Why not just use sort() instead of the double loop?
quoted hunk ↗ jump to hunk
Reported-by: Zeal Robot <redacted>
Signed-off-by: Yang Guang <redacted>
---
  drivers/net/wireless/ath/ath5k/phy.c | 5 +----
  1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/drivers/net/wireless/ath/ath5k/phy.c b/drivers/net/wireless/ath/ath5k/phy.c
index 00f9e347d414..08dc12611f8d 100644
--- a/drivers/net/wireless/ath/ath5k/phy.c
+++ b/drivers/net/wireless/ath/ath5k/phy.c
@@ -1562,16 +1562,13 @@ static s16
  ath5k_hw_get_median_noise_floor(struct ath5k_hw *ah)
  {
  	s16 sort[ATH5K_NF_CAL_HIST_MAX];
-	s16 tmp;
  	int i, j;
  
  	memcpy(sort, ah->ah_nfcal_hist.nfval, sizeof(sort));
  	for (i = 0; i < ATH5K_NF_CAL_HIST_MAX - 1; i++) {
  		for (j = 1; j < ATH5K_NF_CAL_HIST_MAX - i; j++) {
  			if (sort[j] > sort[j - 1]) {
-				tmp = sort[j];
-				sort[j] = sort[j - 1];
-				sort[j - 1] = tmp;
+				swap(sort[j], sort[j - 1]);
  			}
  		}
  	}

-- 
js
suse labs
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help