Re: [PATCH 01/12] iwlwifi: mvm: d3: separate TKIP data from key iteration
From: Luca Coelho <hidden>
Date: 2021-08-26 20:35:47
Luca Coelho [off-list ref] wrote:
From: Johannes Berg <redacted> We do a key iteration to program the keys, and while at it we also collect the data necessary for TKIP. This code has all kinds of dependencies on the firmware API though, so take out the TKIP phase 1 key generation and do that in a separate key iteration only if necessary. Signed-off-by: Johannes Berg <redacted> Signed-off-by: Luca Coelho <redacted>
12 patches applied to iwlwifi-next.git, thanks. 0419e5e672d6 iwlwifi: mvm: d3: separate TKIP data from key iteration 398760aa9679 iwlwifi: mvm: d3: remove fixed cmd_flags argument 631ee5120285 iwlwifi: mvm: d3: refactor TSC/RSC configuration be05fae23d03 iwlwifi: mvm: d3: add separate key iteration for GTK type af3aab9ce298 iwlwifi: mvm: d3: make key reprogramming iteration optional 79e561f0f05a iwlwifi: mvm: d3: implement RSC command version 5 3df5c0ddcf81 iwlwifi: mvm: silently drop encrypted frames for unknown station 967a39832ebe iwlwifi: mvm: Refactor setting of SSIDs for 6GHz scan 6c608cd6962e iwlwifi: mvm: fix access to BSS elements 248e7e2a1d8d iwlwifi: rename ACPI_SAR_NUM_CHAIN_LIMITS to ACPI_SAR_NUM_CHAINS 81870d138dfe iwlwifi: convert flat SAR profile table to a struct version dac7171c8132 iwlwifi: remove ACPI_SAR_NUM_TABLES definition