Re: [PATCH 00/11] Add mt76x0 driver
From: Stanislaw Gruszka <hidden>
Date: 2018-07-20 11:18:11
Also in:
linux-mediatek
On Sat, Jul 07, 2018 at 10:38:27AM +0200, Hans Ulli Kroll wrote:
quoted
quoted
My integration efforts can be traced here: https://github.com/sgruszka/wireless-drivers-next/commits/mt76x0-draftI just had a brief review of the code and I compiled the driver since at the moment I had no adapter for that chipset. As a remainder for future improvements/integration most of the code in dma.c, usb.c (except probe/disconnect functions) and tx.c can use the related routines in the mt76-usb layer (we need to fill function pointer for chipset related stuff if there are differences with mt76x2u, not looked yet). Moreover mcu code can use utility routines in usb-mcu.c I have not looked at mt76x2 common code yet. Regards, LorenzoIt is also possible to reuse struct mt76x2_txwi struct mt76x2_rxwi They have the same memory layout for both mt76x0u and mt76x2u chipsets. Lorenzo can you move them up to mt76.h and rename them to struct mt76_txwi struct mt76_rxwi And we can also do this for struct mt76x2_vif
For the record. I unified bunch of mac80211 callbacks and mac/wcid functions and structures (including structures pointed above) into new mt76xx_lib module. I also rebased the changes on top of latest wireless-drivers-next master and mt76x2u patches in new branch mt76x0-draft-v2: https://github.com/sgruszka/wireless-drivers-next/commits/mt76x0-draft-v2 Regards Stanislaw