Re: Two rtlwifi drivers?
From: Kalle Valo <hidden>
Date: 2017-10-16 13:07:47
Also in:
kernel-janitors
Oleksij Rempel [off-list ref] writes:
quoted
4) As Kalle mentioned, rtlwifi contains many magic numbers, and I plan to fix them after rtl8723de and rtl8821ce. Because the drivers are developing, the changes will make us hard to integrate. However, I don't have plan to process the magic numbers in the module phydm, because the most of BB/RF registers contain many functions. And it doesn't have a register name but a bit field name instead. Our BB team guys say the use of enumeration or defined name will be unreadable, and the name is meaningless for most people.Experience with ath9k driver showed, that development was kind of balanced between two groups, QCA and Community (Other companies, researches, education and so on.). Saying: "you will not understand it any way" is nor really helpful :) Please don't repeat bad experience of Broadcom.
I agree with Oleksij here, but I want to still point out that there are cases when using magic numbers are ok, for example look at ar5008_initvals.h from ath9k. So it depends on case by case. -- Kalle Valo