On Fri, 2017-02-24 at 07:39 -0800, Ben Greear wrote:
On 02/23/2017 10:36 PM, Johannes Berg wrote:
quoted
quoted
+ msg_head = genlmsg_put(skb, 0, 0, &hwsim_genl_family, 0,
+ HWSIM_CMD_NOTIFY);
I think you should use a more specific command name.
My idea was that other attributes could be added over time without
having to add a new cmd-id, so that is why I left it general. If you
still want a different command, do you want it to be something like
'HWSIM_CMD_CHANNEL_CHANGE' ?
We won't run out of command IDs any time soon, so I don't really see a
problem with using a new one for all of those things if needed.
But having a general NOTIFY just means that the application will have
to parse the attributes and understand what means what - that seems
like a case of the cure being worse than the disease?
johannes