Thread (8 messages) flat view 8 messages, 4 authors, 2016-02-04

Re: [PATCH 1/2] rtlwifi: Fix improve function 'rtl_addr_delay()' in core.c

From: Julian Calaby <hidden>
Date: 2016-02-03 02:07:33
Also in: lkml, netdev

Hi Byeounwook,

On Wed, Feb 3, 2016 at 12:59 PM, Byeoungwook Kim [off-list ref] wrote:
Conditional codes in rtl_addr_delay() were improved in readability and
performance by using switch codes.

Signed-off-by: Byeoungwook Kim <redacted>
Reported-by: Julian Calaby <redacted>
Reviewed-by: Julian Calaby <redacted>

Thanks,

Julian Calaby

quoted hunk ↗ jump to hunk
---
 drivers/net/wireless/realtek/rtlwifi/core.c | 20 ++++++++++++++------
 1 file changed, 14 insertions(+), 6 deletions(-)
diff --git a/drivers/net/wireless/realtek/rtlwifi/core.c b/drivers/net/wireless/realtek/rtlwifi/core.c
index 4ae421e..05f432c 100644
--- a/drivers/net/wireless/realtek/rtlwifi/core.c
+++ b/drivers/net/wireless/realtek/rtlwifi/core.c
@@ -37,18 +37,26 @@

 void rtl_addr_delay(u32 addr)
 {
-       if (addr == 0xfe)
+       switch (addr) {
+       case 0xfe:
                mdelay(50);
-       else if (addr == 0xfd)
+               break;
+       case 0xfd:
                mdelay(5);
-       else if (addr == 0xfc)
+               break;
+       case 0xfc:
                mdelay(1);
-       else if (addr == 0xfb)
+               break;
+       case 0xfb:
                udelay(50);
-       else if (addr == 0xfa)
+               break;
+       case 0xfa:
                udelay(5);
-       else if (addr == 0xf9)
+               break;
+       case 0xf9:
                udelay(1);
+               break;
+       };
 }
 EXPORT_SYMBOL(rtl_addr_delay);

--
2.5.0


-- 
Julian Calaby

Email: julian.calaby@gmail.com
Profile: http://www.google.com/profiles/julian.calaby/
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help