On Mon, 2014-10-27 at 12:44 +0200, Jukka Rissanen wrote:
Hi,
patch 1 renames HWSIM_CMD_CREATE_RADIO to HWSIM_CMD_NEW_RADIO and
HWSIM_CMD_DESTROY_RADIO to HWSIM_CMD_DEL_RADIO. They are more
fitting on how other pieces of the wireless system work. A define
to old name is provided for backward compatibility.
That seems reasonable, if a little gratuitous.
Patches 2 and 3 use the newly named enums and provide a way to inform
the listeners on the multicast group "config" when new radio is created
and existing radio is deleted.
Why bother? There are nl80211 events for this already, no?
johannes