Thread (40 messages) 40 messages, 2 authors, 2014-02-28

Re: [RFC/RFT 3/7] ath10k: replace send_head() with tx_sg()

From: Kalle Valo <hidden>
Date: 2014-02-19 12:48:53

Michal Kazior [off-list ref] writes:
PCI is capable of handling scatter-gather lists.
This can be used to avoid copying memory.

Change the name of the callback while at to
reflect its purpose.

Signed-off-by: Michal Kazior <redacted>
[...]
+struct ath10k_hif_sg_item {
+	u16 transfer_id;
+	void *transfer_context;
+	void *vaddr; /* for debugging mostly */
+	u32 paddr;
+	u16 len;
+};
This is the part I don't like. Instead of adding our own structs we
instead should have everything in skb->cb and pass the skbs around. The
sad part was that last fall I was working on cleaning up that but never
found the time to finish it :(

-- 
Kalle Valo
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help