On Wed, Aug 31, 2011 at 4:32 PM, Felix Fietkau [off-list ref] wrote:
reduces unnecessary code duplication. Also takes the sc_pcu_lock within
ath_reset instead of callsites, which makes it possible to always cancel
all queued work items before the reset, possibly fixing a few race
conditions (work items vs reset) along with it.
Signed-off-by: Felix Fietkau <redacted>
This was a bit hard to review, if helpers are being added can they be
added without changing code around, and in some other patch make the
changes you describe?
Luis