On Mon, Aug 8, 2011 at 4:35 PM, Johannes Berg [off-list ref] wrote:
Just a cursory look, I'll send a more detailed review later, but I
wanted to ask John to not merge this for now;
quoted
+static int sta_info_insert_adhoc(struct sta_info *sta) __acquires(RCU)
_ibss would be preferred
quoted
+static int sta_info_insert_mgd(struct sta_info *sta) __acquires(RCU)
_mgd is terribly misleading, this will be done for all modes other than
IBSS.
Fair enough. the _ibss change is logical and understood.
The problem with the _mgd function is that it will be silly to call it
_non_ibss (or is it?)
Do you have a suggestion for a better name?
johannes