Re: [PATCH 4/7] o80211s: (mac80211s) basic mesh interface support
From: Felix Fietkau <hidden>
Date: 2007-11-02 10:02:21
Johannes Berg wrote:
quoted
Agreed about filename length. I would prefer not to make mesh networking configurable, as STA, IBSS, etc modes aren't configurable either. I prefer to avoid polluting the data path with ifdefs.Ok, I'm not sure, it just seems like quite a bit of code especially when all the other features will be added, something people like the OpenWRT folks might not like. nbd?
Depends on how big it is. I think merging it without ifdefs is fine for now. If it gets too big, we can make some ifdef patches later.
quoted
Mesh APs are not supported yet, but we plan to support them through a different interface type (e.g. ..._TYPE_MAP) or extending the AP interface type. Mesh STAs and APs will share all the mesh-specific stuff (peer link discovery, path discovery, etc) but they have little in common in the data path, so I do not think it makes sense to use the same interface type for both. Maybe I should rename ..IF_TYPE_MESH to ..IF_TYPE_MESH_STA?Probably. Come to think of it, how much mesh networking is actually done by the mesh AP? I guess we need to support this in hostapd rather than the kernel?
If we're forced to use hostapd for starting the mesh networking, then that would probably be a bigger source of bloat than the mesh code itself :) - Felix