Re: [PATCH v2] kcov, usb: hide in_serving_softirq checks in __usb_hcd_giveback_urb
From: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Date: 2021-01-07 16:07:28
Also in:
lkml
From: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Date: 2021-01-07 16:07:28
Also in:
lkml
On Thu, Jan 07, 2021 at 05:01:44PM +0100, Andrey Konovalov wrote:
Done opencode in_serving_softirq() checks in __usb_hcd_giveback_urb() to
avoid cluttering the code, hide them in kcov helpers instead.
Fixes: aee9ddb1d371 ("kcov, usb: only collect coverage from __usb_hcd_giveback_urb in softirq")
Signed-off-by: Andrey Konovalov <redacted>
---
Changes v1->v2:
- Fix a typo in the commit description and in a comment in the patch.I can't drop the previous one, so can you just make a follow-on patch please? thanks, greg k-h