Reviews by johannes@sipsolutions.net
· linux-um
All review-attestation trailers
(Reviewed-by / Acked-by /
Tested-by / Reported-by /
Suggested-by / Co-developed-by /
Reported-and-tested-by)
by this address on the linux-um archive.
71 attestations . (47 Acked-by, 19 Reviewed-by, 2 Suggested-by, 3 Tested-by)
-
DORMANTno replies
[PATCH v3] um: drivers: call kernel_strrchr() explicitly in cow_user.c
2026-04-08 · Suggested-by -
STALE111d
[PATCH v2] um: drivers: call kernel_strrchr() explicitly in cow_user.c
2026-04-07 · Suggested-by -
STALE245d
REVIEWED: 8 (8M) Re: [PATCH] arch: um: Don't rename vmap to kernel_vmap
2025-11-24 · Acked-by -
STALE316d
LANDED: 8 (8M) [PATCH RESEND v2] kunit: Enable PCI on UML without triggering WARN()
2025-09-08 · Reviewed-by -
DORMANTno replies
REVIEWED: 8 (8M) [PATCH v2] kunit: Enable PCI on UML without triggering WARN()
2025-08-11 · Reviewed-by -
DORMANTno replies
REVIEWED: 8 (8M) Re: [PATCH] kunit: Enable PCI on UML without triggering WARN()
2025-07-11 · Reviewed-by -
STALE351d
REVIEWED: 16 (16M) Re: [PATCH 21/23] um: ptrace: Use USER_REGSET_NOTE_TYPE() to specify regset note names
2025-07-04 · Acked-by -
STALE351d
REVIEWED: 16 (16M) Re: [PATCH 21/23] um: ptrace: Use USER_REGSET_NOTE_TYPE() to specify regset note names
2025-07-04 · Tested-by -
STALE389d
REVIEWED: 16 (16M) Re: [PATCH v2 1/1] um: virt-pci: Switch to msi_create_parent_irq_domain()
2025-06-30 · Acked-by -
STALE389d
REVIEWED: 16 (16M) Re: [PATCH v2 1/1] um: virt-pci: Switch to msi_create_parent_irq_domain()
2025-06-30 · Tested-by -
DORMANTno replies
REVIEWED: 8 (8M) Re: [PATCH 6/9] kasan/um: call kasan_init_generic in kasan_init
2025-06-25 · Acked-by -
STALE413d
REVIEWED: 8 (8M) Re: [PATCH 2/2] arch: use always-$(KBUILD_BUILTIN) for vmlinux.lds
2025-06-03 · Acked-by -
STALE434d
REVIEWED: 15 (14M) [PATCH AUTOSEL 5.4 4/5] um: let 'make clean' properly clean underlying SUBARCH as well
2025-05-19 · Acked-by -
STALE434d
REVIEWED: 15 (14M) [PATCH AUTOSEL 5.10 4/6] um: let 'make clean' properly clean underlying SUBARCH as well
2025-05-19 · Acked-by -
STALE434d
REVIEWED: 15 (14M) [PATCH AUTOSEL 5.15 4/7] um: let 'make clean' properly clean underlying SUBARCH as well
2025-05-19 · Acked-by -
STALE434d
REVIEWED: 15 (14M) [PATCH AUTOSEL 6.1 4/8] um: let 'make clean' properly clean underlying SUBARCH as well
2025-05-19 · Acked-by -
STALE434d
REVIEWED: 15 (14M) [PATCH AUTOSEL 6.6 05/11] um: let 'make clean' properly clean underlying SUBARCH as well
2025-05-19 · Acked-by -
STALE434d
REVIEWED: 15 (14M) [PATCH AUTOSEL 6.12 05/18] um: let 'make clean' properly clean underlying SUBARCH as well
2025-05-19 · Acked-by -
STALE434d
REVIEWED: 15 (14M) [PATCH AUTOSEL 6.14 07/23] um: let 'make clean' properly clean underlying SUBARCH as well
2025-05-19 · Acked-by -
STALE446d
REVIEWED: 8 (8M) Re: [PATCH -v2] accel/habanalabs: Don't build the driver on UML
2025-05-08 · Reviewed-by -
STALE445d
REVIEWED: 8 (8M) Re: [PATCH] um: let 'make clean' properly clean underlying SUBARCH as well
2025-05-07 · Acked-by -
DORMANTno replies
REVIEWED: 8 (8M) Re: [PATCH] um: Include linux/types.h in asm/fpu/api.h
2025-05-07 · Acked-by -
STALE495d
REVIEWED: 8 (8M) Re: [PATCH 1/2] rust: pass correct target to bindgen on Usermode Linux
2025-03-18 · Acked-by -
DORMANTno replies
REVIEWED: 8 (8M) Re: [PATCH] hostfs: Fix the NULL vs IS_ERR() bug for __filemap_get_folio()
2024-11-08 · Acked-by -
STALE765d
REVIEWED: 19 (18M) [PATCH vhost v9 3/6] virtio: find_vqs: pass struct instead of multi parameters
2024-04-24 · Acked-by -
STALE765d
REVIEWED: 19 (18M) [PATCH vhost v9 4/6] virtio: vring_create_virtqueue: pass struct instead of multi parameters
2024-04-24 · Acked-by -
STALE825d
REVIEWED: 19 (18M) [PATCH vhost v8 4/6] virtio: vring_create_virtqueue: pass struct instead of multi parameters
2024-04-11 · Acked-by -
STALE825d
REVIEWED: 19 (18M) [PATCH vhost v8 3/6] virtio: find_vqs: pass struct instead of multi parameters
2024-04-11 · Acked-by -
STALE823d
REVIEWED: 8 (8M) [PATCH v2 05/25] um: virt-pci: drop owner assignment
2024-03-31 · Acked-by -
STALE852d
REVIEWED: 8 (8M) Re: [PATCH] um: Remove obsolete pcap driver
2024-03-28 · Reviewed-by -
DORMANTno replies
REVIEWED: 8 (8M) Re: [PATCH v2] um: Makefile: use bash from the environment
2024-03-28 · Reviewed-by -
STALE826d
REVIEWED: 8 (8M) Re: [PATCH 1/1] arch/um: fix forward declaration for vmalloc
2024-03-28 · Reviewed-by -
DORMANTno replies
REVIEWED: 8 (8M) Re: [PATCH v3 0/9] um: Minor fixes and cleanups
2024-03-28 · Reviewed-by -
DORMANTno replies
REVIEWED: 8 (8M) Re: [PATCH] um: Fix return value in ubd_init()
2024-03-28 · Reviewed-by -
STALE826d
REVIEWED: 8 (8M) Re: [PATCH] um: Add winch to winch_handlers before registering winch IRQ
2024-03-28 · Reviewed-by -
STALE842d
REVIEWED: 16 (15M) [PATCH vhost v7 4/6] virtio: vring_create_virtqueue: pass struct instead of multi parameters
2024-03-28 · Acked-by -
STALE842d
REVIEWED: 16 (15M) [PATCH vhost v7 3/6] virtio: find_vqs: pass struct instead of multi parameters
2024-03-28 · Acked-by -
STALE849d
REVIEWED: 8 (8M) Re: [PATCH 02/22] um: virt-pci: drop owner assignment
2024-03-27 · Acked-by -
STALE852d
REVIEWED: 15 (15M) [PATCH vhost v6 4/6] virtio: vring_create_virtqueue: pass struct instead of multi parameters
2024-03-27 · Acked-by -
STALE852d
REVIEWED: 15 (15M) [PATCH vhost v6 3/6] virtio: find_vqs: pass struct instead of multi parameters
2024-03-27 · Acked-by -
STALE854d
REVIEWED: 15 (15M) [PATCH vhost v5 4/6] virtio: vring_create_virtqueue: pass struct instead of multi parameters
2024-03-25 · Acked-by -
STALE854d
REVIEWED: 15 (15M) [PATCH vhost v5 3/6] virtio: find_vqs: pass struct instead of multi parameters
2024-03-25 · Acked-by -
STALE853d
REVIEWED: 15 (15M) [PATCH vhost v4 3/6] virtio: find_vqs: pass struct instead of multi parameters
2024-03-21 · Acked-by -
STALE853d
REVIEWED: 15 (15M) [PATCH vhost v4 4/6] virtio: vring_create_virtqueue: pass struct instead of multi parameters
2024-03-21 · Acked-by -
STALE859d
REVIEWED: 15 (15M) [PATCH vhost v3 2/4] virtio: vring_create_virtqueue: pass struct instead of multi parameters
2024-03-12 · Acked-by -
STALE859d
REVIEWED: 15 (15M) [PATCH vhost v3 1/4] virtio: find_vqs: pass struct instead of multi parameters
2024-03-12 · Acked-by -
STALE869d
REVIEWED: 8 (8M) [PATCH vhost v2 2/4] virtio: vring_create_virtqueue: pass struct instead of multi parameters
2024-03-11 · Acked-by -
STALE869d
REVIEWED: 8 (8M) [PATCH vhost v2 1/4] virtio: find_vqs: pass struct instead of multi parameters
2024-03-11 · Acked-by -
STALE872d
REVIEWED: 13 (13M) [PATCH v2 3/3] arch: define CONFIG_PAGE_SIZE_*KB on all architectures
2024-03-06 · Acked-by -
STALE869d
REVIEWED: 8 (8M) [PATCH vhost v1 1/4] virtio: find_vqs: pass struct instead of multi parameters
2024-03-06 · Acked-by -
STALE869d
REVIEWED: 8 (8M) [PATCH vhost v1 2/4] virtio: vring_create_virtqueue: pass struct instead of multi parameters
2024-03-06 · Acked-by -
DORMANTno replies
REVIEWED: 8 (8M) Re: [PATCH 3/4] arch: define CONFIG_PAGE_SIZE_*KB on all architectures
2024-03-05 · Acked-by -
STALE875d
REVIEWED: 8 (8M) Re: [PATCH vhost 2/4] virtio: vring_create_virtqueue: pass struct instead of multi parameters
2024-03-05 · Acked-by -
STALE875d
REVIEWED: 8 (8M) Re: [PATCH vhost 1/4] virtio: find_vqs: pass struct instead of multi parameters
2024-03-05 · Acked-by -
DORMANTno replies
REVIEWED: 8 (8M) Re: [PATCH] um: virt-pci: implement pcibios_get_phb_of_node()
2023-01-20 · Acked-by -
DORMANTno replies
REVIEWED: 8 (8M) Re: [PATCH v2] um: read multiple msg from virtio slave request fd
2022-08-09 · Reviewed-by -
DORMANTno replies
REVIEWED: 8 (8M) Re: [PATCH v4] um: seed rng using host OS rng
2022-07-17 · Acked-by -
STALE1476d
REVIEWED: 8 (8M) [PATCH v5 2/2] UML: add support for KASAN under x86_64
2022-07-01 · Reviewed-by -
STALE1488d
REVIEWED: 8 (8M) [PATCH v4 2/2] UML: add support for KASAN under x86_64
2022-06-30 · Reviewed-by -
STALE1489d
REVIEWED: 8 (8M) [PATCH v3 2/2] UML: add support for KASAN under x86_64
2022-06-30 · Reviewed-by -
STALE1503d
REVIEWED: 8 (8M) Re: [PATCH] um: virt-pci: set device ready in probe()
2022-06-10 · Tested-by -
STALE1489d
REVIEWED: 8 (8M) Re: [PATCH v2 2/2] UML: add support for KASAN under x86_64
2022-05-27 · Reviewed-by -
STALE1498d
REVIEWED: 8 (8M) [PATCH v4 03/12] ptrace/um: Replace PT_DTRACE with TIF_SINGLESTEP
2022-05-05 · Acked-by -
STALE1545d
REVIEWED: 8 (8M) [PATCH v3 03/11] ptrace/um: Replace PT_DTRACE with TIF_SINGLESTEP
2022-05-04 · Acked-by -
STALE1548d
REVIEWED: 8 (8M) [PATCH v2 03/12] ptrace/um: Replace PT_DTRACE with TIF_SINGLESTEP
2022-04-29 · Acked-by -
STALE1552d
REVIEWED: 8 (8M) Re: [PATCH 3/9] ptrace/um: Replace PT_DTRACE with TIF_SINGLESTEP
2022-04-27 · Acked-by -
STALE1547d
REVIEWED: 8 (8M) Re: [PATCH v5 08/11] um: use fallback for random_get_entropy() instead of zero
2022-04-19 · Acked-by -
DORMANTno replies
REVIEWED: 8 (8M) Re: [PATCH -next] um: virt-pci: Fix the application of sizeof to pointer
2021-09-03 · Reviewed-by -
DORMANTno replies
REVIEWED: 8 (8M) Re: [PATCH v3] um: Fix stack pointer alignment
2021-04-20 · Reviewed-by -
STALE1925d
REVIEWED: 8 (8M) Re: [PATCH v2] um: Fix stack pointer alignment
2021-04-19 · Reviewed-by -
STALE2052d
REVIEWED: 8 (8M) Re: [PATCH v4 1/7] um: allow the use of glibc functions instead of builtins
2020-12-11 · Reviewed-by