Reviews by geert@linux-m68k.org
· linux-um
All review-attestation trailers
(Reviewed-by / Acked-by /
Tested-by / Reported-by /
Suggested-by / Co-developed-by /
Reported-and-tested-by)
by this address on the linux-um archive.
100 attestations · capped at 100 most-recent. (72 Acked-by, 2 Reported-by, 22 Reviewed-by, 3 Suggested-by, 1 Tested-by)
-
DORMANTno replies
[PATCH 1/2] um: vector: Clean up and modernize log messages
2025-05-06 · Suggested-by -
DORMANTno replies
[PATCH 2/2] um: vector: Use mac_pton() for MAC address parsing
2025-05-06 · Suggested-by -
STALE556d
REVIEWED: 45 (45M) [PATCH v7] mm/memblock: Add memblock_alloc_or_panic interface
2024-12-22 · Reviewed-by -
STALE648d
REVIEWED: 3 (2M) [PATCH v8 05/14] m68k: Align prototypes of IO memcpy/memset
2024-10-08 · Reviewed-by -
STALE650d
REVIEWED: 4 (4M) Re: [PATCH v7 05/10] m68k: Align prototypes of IO memcpy/memset
2024-09-30 · Reviewed-by -
STALE650d
REVIEWED: 4 (4M) Re: [PATCH v7 05/10] m68k: Align prototypes of IO memcpy/memset
2024-09-30 · Acked-by -
DORMANTno replies
REVIEWED: 2 (2M) Re: [PATCH -next] um: Remove obsoleted declaration for execute_syscall_skas
2024-08-26 · Reviewed-by -
STALE810d
REVIEWED: 2 (2M) Re: [PATCH 2/2] um: virtio_uml: Convert to platform remove callback returning void
2024-03-11 · Reviewed-by -
STALE810d
REVIEWED: 2 (2M) Re: [PATCH 1/2] um: rtc: Convert to platform remove callback returning void
2024-03-11 · Reviewed-by -
STALE862d
REVIEWED: 2 (2M) Re: [PATCH v2 3/3] arch: define CONFIG_PAGE_SIZE_*KB on all architectures
2024-03-06 · Acked-by -
STALE1009d
REVIEWED: 13 (13M) [PATCH mm-unstable v9 22/31] m68k: Convert various functions to use ptdescs
2023-08-07 · Acked-by -
STALE1083d
REVIEWED: 13 (13M) [PATCH mm-unstable v8 22/31] m68k: Convert various functions to use ptdescs
2023-07-31 · Acked-by -
STALE1088d
REVIEWED: 13 (13M) [PATCH mm-unstable v7 22/31] m68k: Convert various functions to use ptdescs
2023-07-25 · Acked-by -
STALE1116d
REVIEWED: 13 (13M) [PATCH v6 24/33] m68k: Convert various functions to use ptdescs
2023-06-27 · Acked-by -
STALE1117d
REVIEWED: 13 (13M) [PATCH v5 24/33] m68k: Convert various functions to use ptdescs
2023-06-22 · Acked-by -
STALE1051d
REVIEWED: 2 (2M) Re: [patch 06/17] m68k/cpu: Switch to arch_cpu_finalize_init()
2023-06-14 · Acked-by -
STALE1124d
REVIEWED: 2 (2M) Re: [PATCH v4 25/34] m68k: Convert various functions to use ptdescs
2023-06-13 · Acked-by -
STALE1082d
REVIEWED: 2 (2M) Re: [PATCH v9 01/42] mm: Rename arch pte_mkwrite()'s to pte_mkwrite_novma()
2023-06-13 · Acked-by -
STALE1150d
REVIEWED: 2 (2M) Re: [PATCH] mm/slab: rename CONFIG_SLAB to CONFIG_SLAB_DEPRECATED
2023-05-23 · Acked-by -
STALE1167d
REVIEWED: 2 (2M) Re: [PATCH v3 01/38] Kconfig: introduce HAS_IOPORT option and select it as necessary
2023-03-14 · Acked-by -
STALE1252d
REVIEWED: 4 (4M) [PATCH v2 2/4] m68k: use asm-generic/memory_model.h for both MMU and !MMU
2023-01-29 · Reviewed-by -
STALE1252d
REVIEWED: 4 (4M) [PATCH v2 2/4] m68k: use asm-generic/memory_model.h for both MMU and !MMU
2023-01-29 · Acked-by -
STALE1268d
REVIEWED: 4 (4M) Re: [PATCH 1/3] m68k: use asm-generic/memory_model.h for both MMU and !MMU
2023-01-26 · Reviewed-by -
STALE1268d
REVIEWED: 4 (4M) Re: [PATCH 1/3] m68k: use asm-generic/memory_model.h for both MMU and !MMU
2023-01-26 · Acked-by -
STALE1216d
LANDED: 15 (13M) [PATCH v3 17/51] objtool/idle: Validate __cpuidle code as noinstr
2023-01-12 · Acked-by -
STALE1334d
REVIEWED: 2 (2M) [PATCH v2 17/44] objtool/idle: Validate __cpuidle code as noinstr
2022-09-19 · Acked-by -
STALE1427d
REVIEWED: 2 (2M) Re: [PATCH] kernel: exit: cleanup release_thread()
2022-08-19 · Acked-by -
STALE1456d
LANDED: 8 (7M) [PATCH v6 4/4] asm-generic: Add new pci.h and use it
2022-07-22 · Acked-by -
STALE1456d
LANDED: 6 (6M) [PATCH v6 2/4] PCI: Move isa_dma_bridge_buggy out of dma.h
2022-07-22 · Acked-by -
STALE1456d
LANDED: 8 (6M) [PATCH v6 1/4] PCI: Remove pci_get_legacy_ide_irq and asm-generic/pci.h
2022-07-22 · Acked-by -
STALE1457d
REVIEWED: 8 (7M) [PATCH v5 4/4] asm-generic: Add new pci.h and use it
2022-07-21 · Acked-by -
STALE1457d
REVIEWED: 6 (6M) [PATCH v5 2/4] PCI: Move isa_dma_bridge_buggy out of dma.h
2022-07-21 · Acked-by -
STALE1457d
REVIEWED: 8 (6M) [PATCH v5 1/4] PCI: Remove pci_get_legacy_ide_irq and asm-generic/pci.h
2022-07-21 · Acked-by -
STALE1459d
REVIEWED: 3 (2M) [PATCH v4 3/3] asm-generic: Add new pci.h and use it
2022-07-20 · Acked-by -
STALE1468d
REVIEWED: 9 (8M) [PATCH V7 26/26] mm/mmap: Drop ARCH_HAS_VM_GET_PAGE_PROT
2022-07-11 · Reviewed-by -
STALE1468d
REVIEWED: 9 (8M) [PATCH V7 26/26] mm/mmap: Drop ARCH_HAS_VM_GET_PAGE_PROT
2022-07-11 · Acked-by -
STALE1468d
REVIEWED: 4 (4M) [PATCH V7 21/26] m68k/mm: Enable ARCH_HAS_VM_GET_PAGE_PROT
2022-07-11 · Reviewed-by -
STALE1468d
REVIEWED: 4 (4M) [PATCH V7 21/26] m68k/mm: Enable ARCH_HAS_VM_GET_PAGE_PROT
2022-07-11 · Acked-by -
STALE1474d
REVIEWED: 4 (4M) Re: [PATCH V6 26/26] mm/mmap: Drop ARCH_HAS_VM_GET_PAGE_PROT
2022-07-06 · Reviewed-by -
STALE1474d
REVIEWED: 4 (4M) Re: [PATCH V6 26/26] mm/mmap: Drop ARCH_HAS_VM_GET_PAGE_PROT
2022-07-06 · Acked-by -
STALE1474d
REVIEWED: 4 (4M) Re: [PATCH V6 21/26] m68k/mm: Enable ARCH_HAS_VM_GET_PAGE_PROT
2022-07-06 · Reviewed-by -
STALE1474d
REVIEWED: 4 (4M) Re: [PATCH V6 21/26] m68k/mm: Enable ARCH_HAS_VM_GET_PAGE_PROT
2022-07-06 · Acked-by -
STALE1283d
REVIEWED: 2 (2M) Re: [PATCH 19/36] objtool/idle: Validate __cpuidle code as noinstr
2022-07-06 · Acked-by -
STALE1510d
REVIEWED: 39 (39M) [PATCH v5] mm: Avoid unnecessary page fault retires on shared memory types
2022-05-30 · Acked-by -
STALE1510d
REVIEWED: 34 (34M) [PATCH v4] mm: Avoid unnecessary page fault retires on shared memory types
2022-05-27 · Acked-by -
STALE1513d
REVIEWED: 2 (2M) Re: [PATCH v3] mm: Avoid unnecessary page fault retires on shared memory types
2022-05-25 · Acked-by -
STALE1538d
REVIEWED: 2 (2M) [PATCH v5 02/11] m68k: use fallback for random_get_entropy() instead of zero
2022-04-19 · Acked-by -
STALE1517d
REVIEWED: 2 (2M) [PATCH v4 02/11] m68k: use fallback for random_get_entropy() instead of zero
2022-04-13 · Acked-by -
STALE1558d
REVIEWED: 2 (2M) Re: [PATCH v3 02/10] m68k: use fallback for random_get_entropy() instead of zero
2022-04-12 · Acked-by -
STALE1605d
REVIEWED: 2 (2M) Re: [PATCH v2 13/18] uaccess: generalize access_ok()
2022-02-18 · Acked-by -
STALE1605d
REVIEWED: 2 (2M) Re: [PATCH v2 08/18] uaccess: add generic __{get,put}_kernel_nofault
2022-02-18 · Acked-by -
STALE1669d
[PATCH] drm/ttm: fix compilation on ARCH=um
2021-12-20 · Reported-by -
STALE1697d
REVIEWED: 2 (2M) Re: [PATCH 2/2] futex: remove futex_cmpxchg detection
2021-10-26 · Acked-by -
STALE1731d
LANDED: 4 (4M) [PATCH 6/9] m68k/emu/nfblock: add error handling support for add_disk()
2021-10-15 · Reviewed-by -
STALE1731d
LANDED: 4 (4M) [PATCH 6/9] m68k/emu/nfblock: add error handling support for add_disk()
2021-10-15 · Acked-by -
STALE1755d
REVIEWED: 4 (4M) [PATCH v2 03/15] m68k/emu/nfblock: add error handling support for add_disk()
2021-09-27 · Reviewed-by -
STALE1755d
REVIEWED: 4 (4M) [PATCH v2 03/15] m68k/emu/nfblock: add error handling support for add_disk()
2021-09-27 · Acked-by -
STALE1773d
REVIEWED: 10 (10M) [PATCH v2 1/3] arch: Export machine_restart() instances so they can be called from modules
2021-09-09 · Acked-by -
STALE1781d
REVIEWED: 4 (4M) Re: [PATCH 03/15] m68k/emu/nfblock: add error handling support for add_disk()
2021-09-01 · Reviewed-by -
STALE1781d
REVIEWED: 4 (4M) Re: [PATCH 03/15] m68k/emu/nfblock: add error handling support for add_disk()
2021-09-01 · Acked-by -
STALE1800d
REVIEWED: 2 (2M) Re: [PATCH v3 9/9] asm-generic: reverse GENERIC_{STRNCPY_FROM,STRNLEN}_USER symbols
2021-07-24 · Acked-by -
STALE1800d
REVIEWED: 4 (4M) [PATCH v3 7/9] asm-generic: uaccess: remove inline strncpy_from_user/strnlen_user
2021-07-22 · Reviewed-by -
STALE1800d
REVIEWED: 4 (4M) [PATCH v3 7/9] asm-generic: uaccess: remove inline strncpy_from_user/strnlen_user
2021-07-22 · Acked-by -
STALE1858d
REVIEWED: 2 (2M) Re: [PATCH v2 1/2] mm: rename pud_page_vaddr to pud_pgtable and make it return pmd_t *
2021-06-15 · Acked-by -
STALE1889d
REVIEWED: 4 (4M) Re: [PATCH 4/5] asm-generic: uaccess: remove inline strncpy_from_user/strnlen_user
2021-05-17 · Reviewed-by -
STALE1889d
REVIEWED: 4 (4M) Re: [PATCH 4/5] asm-generic: uaccess: remove inline strncpy_from_user/strnlen_user
2021-05-17 · Acked-by -
STALE1980d
REVIEWED: 4 (4M) Re: [PATCH 12/27] m68k: syscalls: switch to generic syscalltbl.sh
2021-01-28 · Tested-by -
STALE1980d
REVIEWED: 4 (4M) Re: [PATCH 12/27] m68k: syscalls: switch to generic syscalltbl.sh
2021-01-28 · Acked-by -
STALE1980d
REVIEWED: 2 (2M) Re: [PATCH 11/27] m68k: add missing FORCE and fix 'targets' to make if_changed work
2021-01-28 · Acked-by -
STALE2091d
[PATCH] um: include compiler_attributes.h where used
2020-10-26 · Reported-by -
STALE2129d
REVIEWED: 2 (2M) Re: [PATCH v2] kbuild: preprocess module linker script
2020-09-08 · Acked-by -
STALE2207d
REVIEWED: 2 (2M) Re: [PATCH 6/8] asm-generic: pgalloc: provide generic pgd_free()
2020-06-29 · Acked-by -
STALE2207d
REVIEWED: 2 (2M) Re: [PATCH 1/8] mm: remove unneeded includes of <asm/pgalloc.h>
2020-06-29 · Acked-by -
STALE2205d
REVIEWED: 2 (2M) Re: [PATCH 17/17] arch: rename copy_thread_tls() back to copy_thread()
2020-06-23 · Acked-by -
STALE2205d
REVIEWED: 2 (2M) Re: [PATCH 16/17] arch: remove HAVE_COPY_THREAD_TLS
2020-06-23 · Acked-by -
STALE2243d
REVIEWED: 2 (2M) [PATCH 19/29] mm: rename flush_icache_user_range to flush_icache_user_page
2020-05-15 · Acked-by -
STALE2243d
REVIEWED: 2 (2M) [PATCH 24/29] m68k: implement flush_icache_user_range
2020-05-15 · Acked-by -
STALE2243d
REVIEWED: 4 (4M) [PATCH 29/29] module: move the set_fs hack for flush_icache_range to m68k
2020-05-15 · Reviewed-by -
STALE2243d
REVIEWED: 4 (4M) [PATCH 29/29] module: move the set_fs hack for flush_icache_range to m68k
2020-05-15 · Acked-by -
STALE2258d
REVIEWED: 4 (4M) Re: [PATCH 31/31] module: move the set_fs hack for flush_icache_range to m68k
2020-05-11 · Reviewed-by -
STALE2258d
REVIEWED: 4 (4M) Re: [PATCH 31/31] module: move the set_fs hack for flush_icache_range to m68k
2020-05-11 · Acked-by -
STALE2258d
REVIEWED: 2 (2M) Re: [PATCH 26/31] m68k: implement flush_icache_user_range
2020-05-11 · Acked-by -
STALE2258d
REVIEWED: 2 (2M) Re: [PATCH 21/31] mm: rename flush_icache_user_range to flush_icache_user_page
2020-05-11 · Acked-by -
STALE2327d
REVIEWED: 3 (2M) [PATCH 1/2] mm/vma: Define a default value for VM_DATA_DEFAULT_FLAGS
2020-03-05 · Acked-by -
STALE2321d
REVIEWED: 2 (2M) Re: [RFC 1/3] mm/vma: Define a default value for VM_DATA_DEFAULT_FLAGS
2020-03-02 · Acked-by -
STALE2327d
REVIEWED: 2 (2M) Re: [PATCH] mm/special: Create generic fallbacks for pte_special() and pte_mkspecial()
2020-03-02 · Acked-by -
STALE2441d
REVIEWED: 2 (2M) Re: [PATCH v4 05/13] m68k: mm: use pgtable-nopXd instead of 4level-fixup
2019-11-08 · Acked-by -
STALE2476d
REVIEWED: 2 (2M) Re: [RESEND TRIVIAL 3/3] treewide: arch: Fix Kconfig indentation
2019-10-07 · Acked-by -
STALE2602d
REVIEWED: 4 (4M) [RESEND PATCH 3/4] um: define set_pte_at() as a static inline function, not a macro
2019-04-11 · Reviewed-by -
STALE2684d
REVIEWED: 2 (2M) Re: [PATCH] um: define set_pte_at() as a static inline function, not a macro
2019-03-13 · Reviewed-by -
STALE2479d
REVIEWED: 4 (4M) Re: [PATCH v2 19/21] treewide: add checks for the return value of memblock_alloc*()
2019-01-21 · Reviewed-by -
STALE2479d
REVIEWED: 4 (4M) Re: [PATCH v2 19/21] treewide: add checks for the return value of memblock_alloc*()
2019-01-21 · Acked-by -
STALE2738d
REVIEWED: 2 (2M) Re: [PATCH 13/21] arch: don't memset(0) memory returned by memblock_alloc()
2019-01-16 · Acked-by -
STALE3807d
REVIEWED: 2 (2M) Re: [PATCH 11/22] mtd: Fix dependencies for !HAS_IOMEM archs
2016-01-26 · Acked-by -
STALE3807d
REVIEWED: 2 (2M) Re: [PATCH 04/22] staging: iio: Fix dependencies for !HAS_IOMEM archs
2016-01-26 · Acked-by -
STALE4234d
[PATCH] um: Skip futex_atomic_cmpxchg_inatomic() test
2014-12-10 · Suggested-by -
STALE4267d
REVIEWED: 20 (14M) [PATCH v6 08/48] kernel: Move pm_power_off to common code
2014-11-10 · Acked-by -
STALE4268d
REVIEWED: 20 (14M) [PATCH v5 08/48] kernel: Move pm_power_off to common code
2014-11-06 · Acked-by -
STALE4275d
REVIEWED: 20 (14M) [PATCH v3 08/47] kernel: Move pm_power_off to common code
2014-10-27 · Acked-by -
STALE4282d
REVIEWED: 18 (14M) [PATCH v2 08/47] kernel: Move pm_power_off to common code
2014-10-21 · Acked-by