Thread (8 messages) 8 messages, 3 authors, 17d ago

Re: [PATCH v4 0/4] dmaengine: rename dma_chan::dev to dma_chan::chan_dev for clarity

From: Vinod Koul <vkoul@kernel.org>
Date: 2026-09-15 17:36:21
Also in: dmaengine, imx, linux-arm-kernel, linux-mips, linux-sunxi, linux-tegra, lkml

On Wed, 09 Sep 2026 12:22:27 -0400, Frank.Li@oss.nxp.com wrote:
The current dma_chan structure contains both "device" and "dev". So

    chan->device->dev refers to the DMA engine device.
    chan->dev->device refers to the per-channel device instance.

Their similar naming makes the distinction unclear and increases reader
confusion.

[...]
Applied, thanks!

[1/4] dmaengine: vchan: add vchan_chan_name() to get channel device name
      commit: 75d8640d7f5f89d1a1c39ccb72166ada95fb38d2
[2/4] dmaengine: use dma_chan_name() helper to get per-channel device name
      commit: 76574306c1ac38137683c69407f0e7810f407e4d
[3/4] dmaengine: add (dmaengine|vchan)_chan_dev() helper
      commit: 3b97a3ec420542591c10db8600cf481f1038a011
[4/4] dmaengine: add union chan_dev for dma_chan::dev for clarity
      commit: 6ad1b49cc30dc9bc7c06dd44241e61fe6f82c0b8

Best regards,
-- 
~Vinod

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help