Thread (4 messages) 4 messages, 1 author, 18d ago
COLD18d

Revision v2 of 2 in this series.

Revisions (2)
  1. v1 [diff vs current]
  2. v2 current

[PATCH v2 0/3] ring-buffer: Fix and unify size and page calculations

From: Vincent Donnefort <hidden>
Date: 2026-09-11 19:39:54
Also in: lkml

This short series unifies minimum page calculation for ring buffers and
fix a small issue with the number of pages calculation for trace
remotes.

v2:
  - Add a helper in "Account for ring buffer page header in size
    calculation" (Steven)
  - Split the nr_pages overflow handling into its own patch (Steven)
  - Rename the helpers into __calc_nr_pages_ring_buffer_desc() and
    rb_calculate_nr_pages() (Steven)
  - Use RING_BUFFER_MIN_NR_PAGES in trace_rb_cpu_prepare() (Sashiko)

v1: https://lore.kernel.org/all/20260907192643.42513-1-vdonnefort@google.com (local)

Vincent Donnefort (3):
  tracing/remotes: Account for ring buffer page header in size
    calculation
  tracing/remotes: Catch nr_page_va overflow in ring_buffer_desc sizing
  ring-buffer: Unify ring buffer minimum page calculations

 include/linux/ring_buffer.h       | 26 +++++++++++++++++++++++--
 kernel/trace/ring_buffer.c        | 32 +++++++++++++------------------
 kernel/trace/simple_ring_buffer.c |  4 ++--
 kernel/trace/trace_remote.c       |  6 +++++-
 4 files changed, 44 insertions(+), 24 deletions(-)


base-commit: df2908090cda368b01ff43709f51890076c56157
-- 
2.55.0.1007.g17ff1f9808-goog
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help