A few places in ring-buffer and tracing are using "size" or "entries"
while it means "capacity", that is the amount of memory available for
raw data in a ring buffer. Rename functions and member where
appropriate.
v2:
- Fix "subbufer" typo
- Rename trace_array::entries (Masami)
- Rename tracing_entries_fops and tracing_total_entries_fops
v1 (https://lore.kernel.org/all/20260907094238.3624013-1-vdonnefort@google.com/ (local))
Vincent Donnefort (3):
ring-buffer: Rename ring_buffer_size() to ring_buffer_capacity()
tracing: Rename trace_array::entries to capacity
tracing: Rename tracing_entries_fops to tracing_capacity_fops
include/linux/ring_buffer.h | 2 +-
kernel/trace/ring_buffer.c | 13 ++++++---
kernel/trace/trace.c | 51 +++++++++++++++++------------------
kernel/trace/trace.h | 4 +--
kernel/trace/trace_snapshot.c | 14 +++++-----
5 files changed, 43 insertions(+), 41 deletions(-)
base-commit: df2908090cda368b01ff43709f51890076c56157
--
2.55.0.979.g7e5102b832-goog