Thread (8 messages) flat view 8 messages, 4 authors, 21d ago

Re: [PATCH 1/2] dmaengine: use dma_chan_name() helper to get per-channel device name

From: Logan Gunthorpe <logang@deltatee.com>
Date: 2026-08-13 17:31:03
Also in: dmaengine, imx, linux-arm-kernel, linux-mips, linux-sunxi, linux-tegra, lkml


On 2026-08-12 3:24 p.m., Frank.Li@oss.nxp.com wrote:
From: Frank Li <Frank.Li@nxp.com>

Use the existing dma_chan_name() helper to obtain the per-channel device
name instead of open-coding: dev_name(chan->dev->device) /
dev_name(chan2dev())

Simplify the code and improve consistency.

No functional change intended.

Signed-off-by: Frank Li <Frank.Li@nxp.com>
Makes sense to me.

Reviewed-by: Logan Gunthorpe <logang@deltatee.com>

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help