Thread (25 messages) 25 messages, 2 authors, 23h ago

Re: [PATCH v4 04/17] verification/rvgen: Use pathlib instead of os.path

From: Nam Cao <hidden>
Date: 2026-07-20 07:48:37
Also in: lkml

Gabriele Monaco [off-list ref] writes:
Migrate to the newer patlib library, bundled with python since 3.4 to
increase readability over using os.path.

Signed-off-by: Gabriele Monaco <gmonaco@redhat.com>
...
+            Path(__file__).resolve().parent / "templates" / self.template_dir
That is an interesting use of the division operator.

Reviewed-by: Nam Cao <redacted>
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help