On Mon, Jun 29, 2026 at 01:23:19PM +0100, Lorenzo Stoakes wrote:
The family of vma_interval_tree_() functions manipulate the
address_space (which, of course, is generally referred to as 'mapping')
reverse mapping, but are named the 'VMA' interval tree.
VMAs may be mapped by an anon_vma, an address_space, or both. Therefore
calling the mapping interval tree a 'VMA' interval tree is rather
confusing.
This is also inconsistent with the anon_vma_interval_tree_*() functions
which explicitly reference the rmap object to which they pertain.
Rename the vma_interval_tree_*() functions to mapping_interval_tree_*() to
correct this.
No functional change intended.
Signed-off-by: Lorenzo Stoakes <ljs@kernel.org>
I'll have to nitpick this and say that I prefer [1] file_rmap_tree_, or
mapping_rmap_tree. Or possibly even better - mapping_ (so
mapping_for_each_vma, mapping_insert_vma, etc).
A bit of bikeshedding never hurts ;)
[1] locally I was naming things file_rmap, but I never actually got to
churn these names away
--
Pedro