在 2026/1/26 22:36, Steven Rostedt 写道:
On Mon, 26 Jan 2026 10:43:16 +0800
Yaxiong Tian [off-list ref] wrote:
Hi,
Some of your terminology is a little confusing. The subject says "modules"
but no module will use it (the term module means loadable code at runtime
into the Linux kernel). A better subject would be:
tracing: Rename `eval_map_wq` and allow other parts of tracing use it
quoted
The eval_map_work_func() function, though queued in eval_map_wq,
holds the trace_event_sem read-write lock for a long time during
kernel boot. This causes blocking issues for other functions.
Rename eval_map_wq to trace_init_wq and export it, thereby allowing
Also saying "export" for a function means something like "EXPORT_SYMBOLE()"
which again deals with Linux modules. A better term is "make it global".
quoted
other modules to schedule work on this queue asynchronously and
.. other parts of tracing ..
quoted
avoiding blockage of the main boot thread.
Signed-off-by: Yaxiong Tian <redacted>
Other than that, this patch looks good.
-- Steve
Yes, those statements were not quite accurate. I have addressed them
in Version 3.