st 24. 12. 2025 v 13:51 odesílatel Costa Shulyupin
[off-list ref] napsal:
Both set_pid_cgroup() and set_comm_cgroup() functions contain
identical code for opening the cgroup.procs file.
Extract this common code into a new helper function open_cgroup_procs()
to reduce code duplication and improve maintainability.
Signed-off-by: Costa Shulyupin <redacted>
---
tools/tracing/rtla/src/utils.c | 65 +++++++++++++++++-----------------
1 file changed, 32 insertions(+), 33 deletions(-)
Is this meant to be a v2 of [1] with an updated commit description and comments?
[1] https://lore.kernel.org/all/20251030144231.40058-1-costa.shul@redhat.com/ (local)
Tomas