Re: [PATCH 1/6] module: Add helper function for reading module_buildid()
From: Petr Pavlu <petr.pavlu@suse.com>
Date: 2025-11-06 08:52:16
Also in:
bpf, linux-modules, lkml
From: Petr Pavlu <petr.pavlu@suse.com>
Date: 2025-11-06 08:52:16
Also in:
bpf, linux-modules, lkml
On 11/5/25 3:23 PM, Petr Mladek wrote:
Add a helper function for reading the optional "build_id" member of struct module. It is going to be used also in ftrace_mod_address_lookup(). Use "#ifdef" instead of "#if IS_ENABLED()" to match the declaration of the optional field in struct module. Signed-off-by: Petr Mladek <pmladek@suse.com>
Reviewed-by: Petr Pavlu <petr.pavlu@suse.com> -- Thanks, Petr