Re: [PATCH 02/16] blktrace: add definitions for blk_user_trace_setup2
From: Christoph Hellwig <hch@lst.de>
Date: 2025-09-19 15:07:31
Also in:
linux-block, lkml
From: Christoph Hellwig <hch@lst.de>
Date: 2025-09-19 15:07:31
Also in:
linux-block, lkml
+/*
+ * User setup structure passed with BLKTRACESETUP2
+ */
+struct blk_user_trace_setup2 {
+ char name[32]; /* output */
+ __u64 act_mask; /* input */
+ __u32 buf_size; /* input */
+ __u32 buf_nr; /* input */
+ __u64 start_lba;
+ __u64 end_lba;
+ __u32 pid;
+ __u32 reserved; /* for futute use */I'd rename __reserved to flags, and check that it is zero, and then add a few more __u64 for extensibility.