On Wed, Jan 15, 2025 at 10:18:16PM -0800, Christoph Hellwig wrote:
On Wed, Jan 15, 2025 at 11:31:35AM +0200, Kirill A. Shutemov wrote:
quoted
Now as PG_reclaim is gone, its name can be reclaimed for better
use :)
Rename PG_dropbehind to PG_reclaim and rename all helpers around it.
Why? reclaim is completely generic and reclaim can mean many
different things. dropbehind is much more specific.
Dropbehind is somewhat obscure name. You need fair bit of context to
understand what it does.
But I don't care that much. We can keep it as PG_dropbehind.
Anybody else has opinion on this?
--
Kiryl Shutsemau / Kirill A. Shutemov