Hi Jiaxun,
Thanks for your patch!
On Tue, Sep 3, 2024 at 7:15 PM Jiaxun Yang [off-list ref] wrote:
We have a union and a type both named after mips_instruction,
rust bindgen is not happy with this kind of naming alias.
Given that union mips_instruction is a part of UAPI, the only
thing we can do is to rename mips_instruction type.
Rename it as mips_insn, which is not conflicting with anything
and fits the name of header.
Nit: the header is called inst.h, not insn.h.
Signed-off-by: Jiaxun Yang <jiaxun.yang@flygoat.com>
---
arch/mips/include/asm/dsemul.h | 2 +-
arch/mips/include/asm/inst.h | 6 +++---
Gr{oetje,eeting}s,
Geert
--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@linux-m68k.org
In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
-- Linus Torvalds