Re: [PATCH v2 02/17] vdso: Clean header inclusion in getrandom

From
Jason A. Donenfeld <Jason@zx2c4.com>
Date
2024-08-26 08:58:39
Also in
linux-arch, linux-fsdevel, linux-kselftest, linux-mm, linuxppc-dev, lkml
Reply to
Christophe Leroy, 2024-08-26
On Mon, Aug 26, 2024 at 10:37:49AM +0200, Christophe Leroy wrote:

Le 26/08/2024 à 10:07, Jason A. Donenfeld a écrit :
quoted
On Thu, Aug 22, 2024 at 09:13:10AM +0200, Christophe Leroy wrote:
quoted
  
+#define _PAGE_SIZE (1UL << CONFIG_PAGE_SHIFT)
+#define _PAGE_MASK (~(_PAGE_SIZE - 1))
If PAGE_SIZE isn't defined at this point, why not just call it PAGE_SIZE
instead of _PAGE_SIZE? But if that's the case, why not put the vdso
definition of PAGE_SIZE into some vdso header included by this file?
It was working ok on powerpc but on x86 I got:
Seems like there might be some more fiddling to do, then? Or did you
conclude it's impossible?
Thread (64 messages) 64 messages, 10 authors, last reply 2024-08-30
Keyboard shortcuts
hback out one level
jnext message in thread / next series-diff position
kprevious message in thread / previous series-diff position
ldrill in
Escclose help / fold thread tree
?toggle this help