Thread (2 messages) 2 messages, 2 authors, 2023-09-11

Re: [PATCH] sched: Change the name of preempt mode from full to low_latency

flat view

From: Peter Zijlstra <peterz@infradead.org>
Date: 2023-09-11 22:23:35
Also in: linux-doc, lkml

On Mon, Sep 11, 2023 at 07:00:46PM +0800, Yajun Deng wrote:
There is a similar name fully in Kconfig.preempt, but it corresponds to
PREEMPT_RT. In order to distinguish them, change the name of preempt mode
from full to low_latency.

Also, define a global array and variable that used to save preempt mode
name and size.
Yeah, let's not rename this for giggles. Regular preemption is a fully
preemptible kernel model. No need to invent new names for it.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help