Thread (76 messages) read the whole thread 76 messages, 12 authors, 2023-10-09

Re: [RFC PATCH v2 06/20] tracing/filters: Optimise scalar vs cpumask filtering when the user mask is a single CPU

From: Steven Rostedt <rostedt@goodmis.org>
Date: 2023-07-31 15:55:18
Also in: bpf, kvm, linux-doc, linux-kselftest, linux-mm, lkml, rcu

On Mon, 31 Jul 2023 15:07:52 +0300
Dan Carpenter [off-list ref] wrote:
On Sat, Jul 29, 2023 at 03:55:47PM -0400, Steven Rostedt wrote:
quoted
quoted
@@ -1761,6 +1761,11 @@ static int parse_pred(const char *str, void *data,
 				FILTER_PRED_FN_CPUMASK;
 		} else if (field->filter_type == FILTER_CPU) {
 			pred->fn_num = FILTER_PRED_FN_CPU_CPUMASK;
+		} else if (single) {
+			pred->op = pred->op == OP_BAND ? OP_EQ : pred->op;  
Nit, the above can be written as:

			pred->op = pret->op != OP_BAND ? : OP_EQ;
  
Heh.  Those are not equivalent.  The right way to write this is:
You mean because of my typo?
	if (pred->op == OP_BAND)
		pred->op = OP_EQ;
But sure, I'm fine with that, and it's probably more readable too.

-- Steve
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help