On Monday, August 16, 2021 9:31:25 PM CEST Michael Straube wrote:
Refactor functions rtw_is_cckrates_included() and
rtw_is_cckratesonly_included(). Add new helper function rtw_is_cckrate()
that allows to make the code more compact. Improves readability and
slightly reduces object file size. Change the return type to bool to
reflect that the functions return boolean values.
Suggested-by: Joe Perches <joe@perches.com>
Signed-off-by: Michael Straube <redacted>
---
drivers/staging/r8188eu/core/rtw_ieee80211.c | 27 +++++++++++---------
drivers/staging/r8188eu/include/ieee80211.h | 5 ++--
2 files changed, 17 insertions(+), 15 deletions(-)
Now that you took into account also the second of the two suggestions by Joe
Perches (with a further enhancement he added later), I think that this is
really a good work. Since the first series is gone, here it is a new...
Acked-by: Fabio M. De Francesco <redacted>
Thanks,
Fabio