Thread (14 messages) 14 messages, 3 authors, 25d ago

Re: [PATCH v2 6.12.y 00/10] serial: 8250_dw: backport BUSY deassert series

From: Ilpo Järvinen <ilpo.jarvinen@linux.intel.com>
Date: 2026-06-16 07:57:24

On Tue, 16 Jun 2026, Greg Kroah-Hartman wrote:
On Wed, May 13, 2026 at 01:16:31PM +0300, Ilpo Järvinen wrote:
quoted
On Wed, 13 May 2026, Ionut Nechita (Wind River) wrote:
quoted
From: Ionut Nechita <redacted>

Hi Greg, Ilpo,

This is v2 of the 8250_dw BUSY deassert backport to 6.12.y,
addressing Ilpo's review feedback on v1.
FYI, this came up yesterday related to guard()s vs unlock variants:

https://lore.kernel.org/linux-serial/cover.1778592805.git.jnilo@free.fr/ (local)
Yeah, I'm not going to take these now, I'd like to see a lot more
testing and some actual reasons why this is needed in this tree.  So far
windriver's track-record for backports is really low/bad so I'll just
drop them from my review queue right now.
To be fair, it was me who strongly suggested that the backport should do 
the guard() conversion as well, which contained the bug linked above (and 
the cause there too, was my handiwork), while they initially kept using 
open-coded lock/unlock variants which would not have been subject to that 
problem.

But yes, you guys are the stable maintainers so what to take is your 
decision.

-- 
 i.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help