Thread (3 messages) 3 messages, 2 authors, 2021-10-05

Re: [PATCH] tty: serial: samsung: Improve naming for common macro

flat view

From: Sam Protsenko <semen.protsenko@linaro.org>
Date: 2021-10-05 09:57:15
Also in: linux-arm-kernel, linux-samsung-soc, lkml

On Wed, 15 Sept 2021 at 10:28, Krzysztof Kozlowski
[off-list ref] wrote:
On 14/09/2021 16:23, Sam Protsenko wrote:
quoted
Having "_USI" suffix in EXYNOS_COMMON_SERIAL_DRV_DATA_USI() macro is
confusing. Rename it to just EXYNOS_COMMON_SERIAL_DRV_DATA() and provide
USI registers availability for all Exynos variants instead.

Signed-off-by: Sam Protsenko <semen.protsenko@linaro.org>
---
 drivers/tty/serial/samsung_tty.c | 11 ++++-------
 1 file changed, 4 insertions(+), 7 deletions(-)>
diff --git a/drivers/tty/serial/samsung_tty.c b/drivers/tty/serial/samsung_tty.c
index e2f49863e9c2..542b7e2b99dc 100644
--- a/drivers/tty/serial/samsung_tty.c
+++ b/drivers/tty/serial/samsung_tty.c
@@ -2780,7 +2780,7 @@ static struct s3c24xx_serial_drv_data s5pv210_serial_drv_data = {
 #endif

 #if defined(CONFIG_ARCH_EXYNOS)
-#define EXYNOS_COMMON_SERIAL_DRV_DATA_USI(_has_usi)          \
+#define EXYNOS_COMMON_SERIAL_DRV_DATA(_has_usi)                      \
      .info = &(struct s3c24xx_uart_info) {                   \
              .name           = "Samsung Exynos UART",        \
              .type           = TYPE_S3C6400,                 \
@@ -2804,21 +2804,18 @@ static struct s3c24xx_serial_drv_data s5pv210_serial_drv_data = {
              .has_fracval    = 1,                            \
      }                                                       \

-#define EXYNOS_COMMON_SERIAL_DRV_DATA                                \
-     EXYNOS_COMMON_SERIAL_DRV_DATA_USI(0)
-
 static struct s3c24xx_serial_drv_data exynos4210_serial_drv_data = {
-     EXYNOS_COMMON_SERIAL_DRV_DATA,
+     EXYNOS_COMMON_SERIAL_DRV_DATA(0),
      .fifosize = { 256, 64, 16, 16 },
 };

 static struct s3c24xx_serial_drv_data exynos5433_serial_drv_data = {
-     EXYNOS_COMMON_SERIAL_DRV_DATA,
+     EXYNOS_COMMON_SERIAL_DRV_DATA(0),
      .fifosize = { 64, 256, 16, 256 },
 };

 static struct s3c24xx_serial_drv_data exynos850_serial_drv_data = {
-     EXYNOS_COMMON_SERIAL_DRV_DATA_USI(1),
Makes sense, although I would prefer to have here true or false. More
obvious. Otherwise "1" looks like counter/number for some property.

The has_usi field in struct could be then also converted to bool.
No problem, will send v2 shortly.
Best regards,
Krzysztof
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help