[PATCH v19 0/8] rust: add `Ownable` trait and `Owned` type
From: Andreas Hindborg <a.hindborg@kernel.org>
Date: 2026-06-26 11:55:22
Also in:
dri-devel, driver-core, linux-block, linux-fsdevel, linux-mm, linux-pci, linux-pm, linux-pwm, lkml, rust-for-linux
Add a new trait `Ownable` and type `Owned` for types that specify their own way of performing allocation and destruction. This is useful for types from the C side. Implement `ForeignOwnable` for `Owned`. Convert `Page` to be `Ownable` and add a `from_raw` method. Add the trait `OwnableRefCounted` that allows conversion between `ARef` and `Owned`. This is analogous to conversion between `Arc` and `UniqueArc`. Patches 1-4 implement `Ownable` and applies it to `Page`. These patches can be merged on their own. Patches 5-7 add `Ownable` -> `ARef` interop and can be merged later if consensus on their shape cannot be reached. Signed-off-by: Andreas Hindborg <a.hindborg@kernel.org> --- Changes in v19: - Update `workqueue.rs` and the `aref` module docs to use `RefCounted` instead of `AlwaysRefCounted` (Sashiko). - Remove the default `OwnableRefCounted::into_shared` implementation to keep the trait safe (Sashiko). - Fix the `ARef<Self>` rustdoc link (Sashiko). - Reuse `Owned::into_raw`/`from_raw` in the `ForeignOwnable` implementation (Gary). - Link to v18: https://msgid.link/20260625-unique-ref-v18-0-4e06b5896d47@kernel.org Changes in v18: - Rebase on `rust-next` (2026-06-24). - Drop the `'static` bound on `ForeignOwnable for Owned` (Gary). - Make `Ownable::release` take a raw pointer instead of `&mut self` (Alice, Sashiko). - Drop `types::ARef` re-export (Alice). - Drop unneeded `#[repr(transparent)]` on `Owned` (Gary). - Fix `FOREIGN_ALIGN` for `Owned` to report the pointee alignment (Sashiko). - Remove `BorrowedPage`; use `&Page` directly (Alice). - Update Rust Binder for the `Owned<Page>` conversion (Alice). - Update `pwm.rs` for the `RefCounted`/`AlwaysRefCounted` split (Sashiko). - Fix documentation nits: missing `// INVARIANT:` comments, stale `Page` docs, and a stray `mut` (Sashiko). - Expand the `use` statements touched by the rename patch to the multi-line style (Onur). - Link to v17: https://msgid.link/20260604-unique-ref-v17-0-7b4c3d2930b9@kernel.org Changes in v17: - Rebase on v7.1-rc2. - Reorder patches so that `Ownable` can merge without `OwnableRefCounted` (Alice). - Add `#[inline]` directives to short functions added by the series (Gary). - Link to v16: https://msgid.link/20260224-unique-ref-v16-0-c21afcb118d3@kernel.org Changes in v16: - Simplify pointer to reference cast in `Page::from_raw`. - Use `NonNull<Page>` rather than `Owned<Page>` for `BorrowedPage` internals. - Use "convertible to reference" wording when converting pointers to references. - Fix formatting for `Page::from_raw` docs. - Leave imports alone when adding safety comment to aref example. - Use `KBox::into_nonnull` for examples. - Add patch for `KBox::into_nonnull`. - Change invariants and safety comments of `Ownable` and make the trait safe. - Make `Ownable::release` take a mutable reference. - Fix error handling in example for `Ownable` - Link to v15: https://msgid.link/20260220-unique-ref-v15-0-893ed86b06cc@kernel.org Changes in v15: - Update series with original SoB's. - Rename `AlwaysRefCounted` in `kernel::usb`. - Rename `Owned::get_pin_mut` to `Owned::as_pin_mut`. - Link to v14: https://msgid.link/20260204-unique-ref-v14-0-17cb29ebacbb@kernel.org Changes in v14: - Rebase on v6.19-rc7. - Rewrite cover letter. - Update documentation and safety comments based on v13 feedback. - Update commit messages. - Reorder implementation blocks in owned.rs. - Update example in owned.rs to use try operator rather than `expect`. - Reformat use statements. - Add patch: rust: page: convert to `Ownable`. - Add patch: rust: implement `ForeignOwnable` for `Owned`. - Add patch: rust: page: add `from_raw()`. - Link to v13: https://lore.kernel.org/r/20251117-unique-ref-v13-0-b5b243df1250@pm.me (local) Changes in v13: - Rebase onto v6.18-rc1 (Andreas's work). - Documentation and style fixes contributed by Andreas - Link to v12: https://lore.kernel.org/r/20251001-unique-ref-v12-0-fa5c31f0c0c4@pm.me (local) Changes in v12: - - Rebase onto v6.17-rc1 (Andreas's work). - moved kernel/types/ownable.rs to kernel/owned.rs - Drop OwnableMut, make DerefMut depend on Unpin instead. I understood ML discussion as that being okay, but probably needs further scrunity. - Lots of more documentation changes suggested by reviewers. - Usage example for Ownable/Owned. - Link to v11: https://lore.kernel.org/r/20250618-unique-ref-v11-0-49eadcdc0aa6@pm.me (local) Changes in v11: - Rework of documentation. I tried to honor all requests for changes "in spirit" plus some clearifications and corrections of my own. - Dropping `SimpleOwnedRefCounted` by request from Alice, as it creates a potentially problematic blanket implementation (which a derive macro that could be created later would not have). - Dropping Miguel's "kbuild: provide `RUSTC_HAS_DO_NOT_RECOMMEND` symbol" patch, as it is not needed anymore after dropping `SimpleOwnedRefCounted`. (I can add it again, if it is considered useful anyway). - Link to v10: https://lore.kernel.org/r/20250502-unique-ref-v10-0-25de64c0307f@pm.me (local) Changes in v10: - Moved kernel/ownable.rs to kernel/types/ownable.rs - Fixes in documentation / comments as suggested by Andreas Hindborg - Added Reviewed-by comment for Andreas Hindborg - Fix rustfmt of pid_namespace.rs - Link to v9: https://lore.kernel.org/r/20250325-unique-ref-v9-0-e91618c1de26@pm.me (local) Changes in v9: - Rebase onto v6.14-rc7 - Move Ownable/OwnedRefCounted/Ownable, etc., into separate module - Documentation fixes to Ownable/OwnableMut/OwnableRefCounted - Add missing SAFETY documentation to ARef example - Link to v8: https://lore.kernel.org/r/20250313-unique-ref-v8-0-3082ffc67a31@pm.me (local) Changes in v8: - Fix Co-developed-by and Suggested-by tags as suggested by Miguel and Boqun - Some small documentation fixes in Owned/Ownable patch - removing redundant trait constraint on DerefMut for Owned as suggested by Boqun Feng - make SimpleOwnedRefCounted no longer implement RefCounted as suggested by Boqun Feng - documentation for RefCounted as suggested by Boqun Feng - Link to v7: https://lore.kernel.org/r/20250310-unique-ref-v7-0-4caddb78aa05@pm.me (local) Changes in v7: - Squash patch to make Owned::from_raw/into_raw public into parent - Added Signed-off-by to other people's commits - Link to v6: https://lore.kernel.org/r/20250310-unique-ref-v6-0-1ff53558617e@pm.me (local) Changes in v6: - Changed comments/formatting as suggested by Miguel Ojeda - Included and used new config flag RUSTC_HAS_DO_NOT_RECOMMEND, thus no changes to types.rs will be needed when the attribute becomes available. - Fixed commit message for Owned patch. - Link to v5: https://lore.kernel.org/r/20250307-unique-ref-v5-0-bffeb633277e@pm.me (local) Changes in v5: - Rebase the whole thing on top of the Ownable/Owned traits by Asahi Lina. - Rename AlwaysRefCounted to RefCounted and make AlwaysRefCounted a marker trait instead to allow to obtain an ARef<T> from an &T, which (as Alice pointed out) is unsound when combined with UniqueRef/Owned. - Change the Trait design and naming to implement this feature, UniqueRef/UniqueRefCounted is dropped in favor of Ownable/Owned and OwnableRefCounted is used to provide the functions to convert between Owned and ARef. - Link to v4: https://lore.kernel.org/r/20250305-unique-ref-v4-1-a8fdef7b1c2c@pm.me (local) Changes in v4: - Just a minor change in naming by request from Andreas Hindborg, try_shared_to_unique() -> try_from_shared(), unique_to_shared() -> into_shared(), which is more in line with standard Rust naming conventions. - Link to v3: https://lore.kernel.org/r/Z8Wuud2UQX6Yukyr@mango (local) To: Danilo Krummrich <dakr@kernel.org> To: Lorenzo Stoakes <ljs@kernel.org> To: Vlastimil Babka <vbabka@kernel.org> To: "Liam R. Howlett" <liam@infradead.org> To: Uladzislau Rezki <urezki@gmail.com> To: Miguel Ojeda <ojeda@kernel.org> To: Boqun Feng <boqun@kernel.org> To: Gary Guo <gary@garyguo.net> To: Björn Roy Baron <bjorn3_gh@protonmail.com> To: Benno Lossin <lossin@kernel.org> To: Andreas Hindborg <a.hindborg@kernel.org> To: Alice Ryhl <aliceryhl@google.com> To: Trevor Gross <tmgross@umich.edu> To: Daniel Almeida <daniel.almeida@collabora.com> To: Tamir Duberstein <tamird@kernel.org> To: Alexandre Courbot <acourbot@nvidia.com> To: Onur Özkan <work@onurozkan.dev> To: Lyude Paul <lyude@redhat.com> To: Greg Kroah-Hartman <gregkh@linuxfoundation.org> To: Arve Hjønnevåg <arve@android.com> To: Todd Kjos <tkjos@android.com> To: Christian Brauner <brauner@kernel.org> To: Carlos Llamas <cmllamas@google.com> To: "Rafael J. Wysocki" <rafael@kernel.org> To: Dave Ertman <david.m.ertman@intel.com> To: Ira Weiny <redacted> To: Leon Romanovsky <leon@kernel.org> To: Paul Moore <paul@paul-moore.com> To: Serge Hallyn <sergeh@kernel.org> To: David Airlie <airlied@gmail.com> To: Simona Vetter <simona@ffwll.ch> To: Alexander Viro <viro@zeniv.linux.org.uk> To: Jan Kara <jack@suse.cz> To: Igor Korotin <igor.korotin@linux.dev> To: Viresh Kumar <vireshk@kernel.org> To: Nishanth Menon <nm@ti.com> To: Stephen Boyd <sboyd@kernel.org> To: Bjorn Helgaas <bhelgaas@google.com> To: Krzysztof Wilczyński <kwilczynski@kernel.org> To: Pavel Tikhomirov <ptikhomirov@virtuozzo.com> To: Michal Wilczynski <m.wilczynski@samsung.com> Cc: Philipp Stanner <phasta@kernel.org> Cc: rust-for-linux@vger.kernel.org Cc: linux-kernel@vger.kernel.org Cc: linux-mm@kvack.org Cc: driver-core@lists.linux.dev Cc: linux-block@vger.kernel.org Cc: linux-security-module@vger.kernel.org Cc: dri-devel@lists.freedesktop.org Cc: linux-fsdevel@vger.kernel.org Cc: linux-pm@vger.kernel.org Cc: linux-pci@vger.kernel.org Cc: linux-pwm@vger.kernel.org --- Andreas Hindborg (3): rust: alloc: add `KBox::into_non_null` rust: implement `ForeignOwnable` for `Owned` rust: page: add `from_raw()` Asahi Lina (2): rust: types: Add Ownable/Owned types rust: page: convert to `Ownable` Oliver Mangold (3): rust: rename `AlwaysRefCounted` to `RefCounted`. rust: Add missing SAFETY documentation for `ARef` example rust: Add `OwnableRefCounted` drivers/android/binder/page_range.rs | 10 +- rust/kernel/alloc/allocator.rs | 19 +- rust/kernel/alloc/allocator/iter.rs | 6 +- rust/kernel/alloc/kbox.rs | 9 + rust/kernel/auxiliary.rs | 10 +- rust/kernel/block/mq/request.rs | 19 +- rust/kernel/cred.rs | 16 +- rust/kernel/device.rs | 12 +- rust/kernel/device/property.rs | 11 +- rust/kernel/drm/device.rs | 9 +- rust/kernel/drm/gem/mod.rs | 16 +- rust/kernel/fs/file.rs | 23 ++- rust/kernel/i2c.rs | 13 +- rust/kernel/lib.rs | 1 + rust/kernel/mm.rs | 22 ++- rust/kernel/mm/mmput_async.rs | 12 +- rust/kernel/opp.rs | 16 +- rust/kernel/owned.rs | 373 +++++++++++++++++++++++++++++++++++ rust/kernel/page.rs | 136 +++++-------- rust/kernel/pci.rs | 10 +- rust/kernel/pid_namespace.rs | 15 +- rust/kernel/platform.rs | 10 +- rust/kernel/pwm.rs | 12 +- rust/kernel/sync/aref.rs | 84 +++++--- rust/kernel/task.rs | 13 +- rust/kernel/types.rs | 12 ++ rust/kernel/usb.rs | 17 +- rust/kernel/workqueue.rs | 8 +- 28 files changed, 728 insertions(+), 186 deletions(-) --- base-commit: 43a393185e33e573a374c1d4f7ddf6481484ef8d change-id: 20250305-unique-ref-29fcd675f9e9 Best regards, -- Andreas Hindborg [off-list ref]