<snip>
How about security_task_prctl_allowed()? (Mirroring security_uring_*)
Renaming the existing hook security_task_prctl_handle() also wouldn't
be too bad, but that's probably more churn than it's worth.
Yeah if something else is already done, I'll just copy their
convention. I went with suffix _check for now.
Another possible issue that I think other upstream communities may
have with adding an additional hook, is that there will be two hooks
in the prctl syscall path,
I am not sure if that's a show stopper?