Thread (9 messages) 9 messages, 4 authors, 2024-12-04

Re: [PATCH] selftests: lsm: Refactor `flags_overset_lsm_set_self_attr` test

From: Shuah Khan <skhan@linuxfoundation.org>
Date: 2024-11-14 17:08:37
Also in: linux-kernel-mentees, linux-kselftest, lkml

On 11/14/24 09:55, Casey Schaufler wrote:
On 11/14/2024 8:25 AM, Shuah Khan wrote:
quoted
On 11/12/24 11:28, Amit Vadhavana wrote:
quoted
- Remove unnecessary `tctx` variable, use `ctx` directly.
- Simplified code with no functional changes.
I would rephrase the short to simply say Remove unused variable,
as refactor implies more extensive changes than what this patch
is actually doing.

Please write complete sentences instead of bullet points in the
change log.

How did you find this problem? Do include the details on how
in the change log.
quoted
Signed-off-by: Amit Vadhavana <redacted>
---
   tools/testing/selftests/lsm/lsm_set_self_attr_test.c | 7 +++----
   1 file changed, 3 insertions(+), 4 deletions(-)
diff --git a/tools/testing/selftests/lsm/lsm_set_self_attr_test.c
b/tools/testing/selftests/lsm/lsm_set_self_attr_test.c
index 66dec47e3ca3..732e89fe99c0 100644
--- a/tools/testing/selftests/lsm/lsm_set_self_attr_test.c
+++ b/tools/testing/selftests/lsm/lsm_set_self_attr_test.c
@@ -56,16 +56,15 @@ TEST(flags_zero_lsm_set_self_attr)
   TEST(flags_overset_lsm_set_self_attr)
   {
       const long page_size = sysconf(_SC_PAGESIZE);
-    char *ctx = calloc(page_size, 1);
+    struct lsm_ctx *ctx = calloc(page_size, 1);
Why not name this tctx and avoid changes to the ASSERT_EQs
below?
In the realm of linux security modules ctx is short for "context".
I used tctx here because I was lazy. It would be much better to
drop tctx, even if it means a tiny bit more change.
Makes sense.

Amit, you can ignore this comment about tctx and ctx. Please do fix
others about the change log and short log.

thanks,
-- Shuah
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help