Re: [PATCH 3/16] capability: rename cpu_vfs_cap_data to vfs_caps
From: Paul Moore <paul@paul-moore.com>
Date: 2023-12-05 21:25:28
Also in:
linux-fsdevel, linux-unionfs, lkml
From: Paul Moore <paul@paul-moore.com>
Date: 2023-12-05 21:25:28
Also in:
linux-fsdevel, linux-unionfs, lkml
On Nov 29, 2023 "Seth Forshee (DigitalOcean)" [off-list ref] wrote:
vfs_caps is a more generic name which is better suited to the broader use this struct will see in subsequent commits. Signed-off-by: Seth Forshee (DigitalOcean) <sforshee@kernel.org> Reviewed-by: Christian Brauner <brauner@kernel.org> --- include/linux/capability.h | 4 ++-- kernel/auditsc.c | 4 ++-- security/commoncap.c | 8 ++++---- 3 files changed, 8 insertions(+), 8 deletions(-)
Bonus points in that the proposed name is shorter too :) Technically you'll want to get Serge's ACK as he's the capabilities maintainer, but with my LSM hat on this looks okay, and is pretty trivial anyway. Acked-by: Paul Moore <paul@paul-moore.com> (Audit,LSM) -- paul-moore.com