Thread (3 messages) 3 messages, 2 authors, 2021-10-01

Re: [PATCH][next] apparmor: Use struct_size() helper in kzalloc()

flat view

From: "Gustavo A. R. Silva" <gustavoars@kernel.org>
Date: 2021-10-01 23:45:05
Also in: linux-hardening, lkml

On Fri, Oct 01, 2021 at 04:37:08PM -0700, John Johansen wrote:
On 9/29/21 3:05 PM, Gustavo A. R. Silva wrote:
quoted
Make use of the struct_size() helper instead of an open-coded version,
in order to avoid any potential type mistakes or integer overflows that,
in the worse scenario, could lead to heap overflows.
quoted
Link: https://github.com/KSPP/linux/issues/160
Signed-off-by: Gustavo A. R. Silva <gustavoars@kernel.org>
nice

I will pull this into my tree
Acked-by: John Johansen <john.johansen@canonical.com>
Thanks, John.

--
Gustavo
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help