On Wed, Jul 1, 2020 at 10:23 AM Eric W. Biederman [off-list ref] wrote:
Linus Torvalds [off-list ref] writes:
quoted
On Mon, Jun 29, 2020 at 1:05 PM Eric W. Biederman [off-list ref] wrote:
quoted
This makes it clear which code is part of the core user mode
helper support and which code is needed to implement user mode
drivers.
kernel/umd.c | 146 +++++++++++++++++++++++++++++++++++++++
kernel/umh.c | 139 -------------------------------------
I certainly don't object to the split, but I hate the name.
We have uml, umd and umh for user mode {linux, drivers, helper}
respectively.And honestly, I don't see the point in using an obscure
and unreadable TLA for something like this.
I really don't think it would hurt to write out even the full name
with "usermode_driver.c" or something like that, would it?
Then "umd" could be continued to be used as a prefix for the helper
functions, by all means, but if we startv renaming files, can we do it
properly?
I will take care of it. I have to respin the patchset for a silly bug anyways.
I guess with the header name too: umd.h -> usermode_driver.h ?