Thread (3 messages) 3 messages, 2 authors, 2020-01-27

Denying access from sb_umount issue

From: Alexander Ivanov <hidden>
Date: 2020-01-27 20:33:38

The lsm module implementes sb_umount() hook to disable lazy umounts. When access is denied, all consecutive umounts fail. It looks like mount reference count is messed up when sb_umount() return -EPERM. Is it possible that umount syscall assumes do_umount() touches those references and it calls 

 dput(path.dentry);
 mntput_no_expire(mnt);

regardless of what do_mount() returns?

Thanks,
--Alex
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help